debian/rules
changeset 29 08ec6ddd6eea
parent 0 586472add385
child 31 bbcb8a3366b4
equal deleted inserted replaced
28:ef929533d040 29:08ec6ddd6eea
    15 configure: configure-stamp
    15 configure: configure-stamp
    16 configure-stamp:
    16 configure-stamp:
    17 	dh_testdir
    17 	dh_testdir
    18 	# Add here commands to configure the package.
    18 	# Add here commands to configure the package.
    19 
    19 
    20 	cmake src/
       
    21 	touch configure-stamp
    20 	touch configure-stamp
    22 
    21 
    23 
    22 
    24 build: build-stamp
    23 build: build-stamp
    25 
    24 
    36 	dh_testdir
    35 	dh_testdir
    37 	dh_testroot
    36 	dh_testroot
    38 	rm -f build-stamp configure-stamp
    37 	rm -f build-stamp configure-stamp
    39 
    38 
    40 	# Add here commands to clean up after the build process.
    39 	# Add here commands to clean up after the build process.
    41 	if [ -f Makefile ]; then $(MAKE) clean; fi
    40 	$(MAKE) distclean
    42 	rm -rf Makefile CMake* install* mcbot dbtool cmake_install.cmake
       
    43 	dh_clean 
    41 	dh_clean 
    44 
    42 
    45 install: build
    43 install: build
    46 	dh_testdir
    44 	dh_testdir
    47 	dh_testroot
    45 	dh_testroot