debian/rules
changeset 0 586472add385
child 29 08ec6ddd6eea
equal deleted inserted replaced
-1:000000000000 0:586472add385
       
     1 #!/usr/bin/make -f
       
     2 # -*- makefile -*-
       
     3 # Sample debian/rules that uses debhelper.
       
     4 # This file was originally written by Joey Hess and Craig Small.
       
     5 # As a special exception, when this file is copied by dh-make into a
       
     6 # dh-make output file, you may use that output file without restriction.
       
     7 # This special exception was added by Craig Small in version 0.37 of dh-make.
       
     8 
       
     9 # Uncomment this to turn on verbose mode.
       
    10 #export DH_VERBOSE=1
       
    11 
       
    12 
       
    13 
       
    14 
       
    15 configure: configure-stamp
       
    16 configure-stamp:
       
    17 	dh_testdir
       
    18 	# Add here commands to configure the package.
       
    19 
       
    20 	cmake src/
       
    21 	touch configure-stamp
       
    22 
       
    23 
       
    24 build: build-stamp
       
    25 
       
    26 build-stamp: configure-stamp 
       
    27 	dh_testdir
       
    28 
       
    29 	# Add here commands to compile the package.
       
    30 	$(MAKE)
       
    31 	#docbook-to-man debian/mcbot.sgml > mcbot.1
       
    32 
       
    33 	touch $@
       
    34 
       
    35 clean:
       
    36 	dh_testdir
       
    37 	dh_testroot
       
    38 	rm -f build-stamp configure-stamp
       
    39 
       
    40 	# Add here commands to clean up after the build process.
       
    41 	if [ -f Makefile ]; then $(MAKE) clean; fi
       
    42 	rm -rf Makefile CMake* install* mcbot dbtool cmake_install.cmake
       
    43 	dh_clean 
       
    44 
       
    45 install: build
       
    46 	dh_testdir
       
    47 	dh_testroot
       
    48 	dh_clean -k 
       
    49 	dh_installdirs
       
    50 
       
    51 	# Add here commands to install the package into debian/mcbot.
       
    52 	$(MAKE) DESTDIR=$(CURDIR)/debian/mcbot install
       
    53 	cp config/.mcbotrc debian/mcbot/var/lib/nobody/
       
    54 
       
    55 # Build architecture-independent files here.
       
    56 binary-indep: build install
       
    57 # We have nothing to do by default.
       
    58 
       
    59 # Build architecture-dependent files here.
       
    60 binary-arch: build install
       
    61 	dh_testdir
       
    62 	dh_testroot
       
    63 	dh_installchangelogs 
       
    64 	dh_installdocs
       
    65 	dh_installexamples
       
    66 #	dh_install
       
    67 #	dh_installmenu
       
    68 #	dh_installdebconf	
       
    69 #	dh_installlogrotate
       
    70 #	dh_installemacsen
       
    71 #	dh_installpam
       
    72 #	dh_installmime
       
    73 #	dh_python
       
    74 #	dh_installinit
       
    75 #	dh_installcron
       
    76 #	dh_installinfo
       
    77 	dh_installman
       
    78 	dh_link
       
    79 	dh_strip
       
    80 	dh_compress
       
    81 	dh_fixperms
       
    82 #	dh_perl
       
    83 #	dh_makeshlibs
       
    84 	dh_installdeb
       
    85 	dh_shlibdeps
       
    86 	dh_gencontrol
       
    87 	dh_md5sums
       
    88 	dh_builddeb
       
    89 
       
    90 binary: binary-indep binary-arch
       
    91 .PHONY: build clean binary-indep binary-arch binary install configure