|
1 #!/usr/bin/make -f |
|
2 # -*- makefile -*- |
|
3 # Sample debian/rules that uses debhelper. |
|
4 # This file was originally written by Joey Hess and Craig Small. |
|
5 # As a special exception, when this file is copied by dh-make into a |
|
6 # dh-make output file, you may use that output file without restriction. |
|
7 # This special exception was added by Craig Small in version 0.37 of dh-make. |
|
8 |
|
9 # Uncomment this to turn on verbose mode. |
|
10 #export DH_VERBOSE=1 |
|
11 |
|
12 |
|
13 |
|
14 |
|
15 configure: configure-stamp |
|
16 configure-stamp: |
|
17 dh_testdir |
|
18 # Add here commands to configure the package. |
|
19 |
|
20 touch configure-stamp |
|
21 |
|
22 |
|
23 build: build-stamp |
|
24 |
|
25 build-stamp: configure-stamp |
|
26 dh_testdir |
|
27 |
|
28 # Add here commands to compile the package. |
|
29 ./build |
|
30 #docbook-to-man debian/qmonitor.sgml > qmonitor.1 |
|
31 |
|
32 touch $@ |
|
33 |
|
34 clean: |
|
35 dh_testdir |
|
36 dh_testroot |
|
37 rm -f build-stamp configure-stamp |
|
38 |
|
39 # Add here commands to clean up after the build process. |
|
40 if [ -f Makefile ]; then $(MAKE) distclean; fi |
|
41 rm -f qmonitor qmonitor-0.10.pro |
|
42 dh_clean |
|
43 |
|
44 install: build |
|
45 dh_testdir |
|
46 dh_testroot |
|
47 dh_clean -k |
|
48 dh_installdirs |
|
49 |
|
50 # Add here commands to install the package into debian/qmonitor. |
|
51 mv qmonitor-0 qmonitor |
|
52 install -d debian/qmonitor/usr/sbin/ |
|
53 install qmonitor debian/qmonitor/usr/sbin/ |
|
54 ./post-install; |
|
55 |
|
56 |
|
57 # Build architecture-independent files here. |
|
58 binary-indep: build install |
|
59 # We have nothing to do by default. |
|
60 |
|
61 # Build architecture-dependent files here. |
|
62 binary-arch: build install |
|
63 dh_testdir |
|
64 dh_testroot |
|
65 dh_installchangelogs |
|
66 dh_installdocs |
|
67 dh_installexamples |
|
68 # dh_install |
|
69 # dh_installmenu |
|
70 # dh_installdebconf |
|
71 # dh_installlogrotate |
|
72 # dh_installemacsen |
|
73 # dh_installpam |
|
74 # dh_installmime |
|
75 # dh_python |
|
76 # dh_installinit |
|
77 # dh_installcron |
|
78 # dh_installinfo |
|
79 dh_installman |
|
80 dh_link |
|
81 dh_strip |
|
82 dh_compress |
|
83 dh_fixperms |
|
84 # dh_perl |
|
85 # dh_makeshlibs |
|
86 dh_installdeb |
|
87 dh_shlibdeps |
|
88 dh_gencontrol |
|
89 dh_md5sums |
|
90 dh_builddeb |
|
91 |
|
92 binary: binary-indep binary-arch |
|
93 .PHONY: build clean binary-indep binary-arch binary install configure |