equal
deleted
inserted
replaced
20 touch configure-stamp |
20 touch configure-stamp |
21 |
21 |
22 |
22 |
23 build: build-stamp |
23 build: build-stamp |
24 |
24 |
25 build-stamp: configure-stamp |
25 build-stamp: configure-stamp |
26 dh_testdir |
26 dh_testdir |
27 |
27 |
28 # Add here commands to compile the package. |
28 # Add here commands to compile the package. |
29 $(MAKE) |
29 $(MAKE) |
30 #docbook-to-man debian/mcbot.sgml > mcbot.1 |
30 #docbook-to-man debian/mcbot.sgml > mcbot.1 |
36 dh_testroot |
36 dh_testroot |
37 rm -f build-stamp configure-stamp |
37 rm -f build-stamp configure-stamp |
38 |
38 |
39 # Add here commands to clean up after the build process. |
39 # Add here commands to clean up after the build process. |
40 $(MAKE) distclean |
40 $(MAKE) distclean |
41 dh_clean |
41 dh_clean |
42 |
42 |
43 install: build |
43 install: build |
44 dh_testdir |
44 dh_testdir |
45 dh_testroot |
45 dh_testroot |
46 dh_clean -k |
46 dh_clean -k |
47 dh_installdirs |
47 dh_installdirs |
48 |
48 |
49 # Add here commands to install the package into debian/mcbot. |
49 # Add here commands to install the package into debian/mcbot. |
50 $(MAKE) DESTDIR=$(CURDIR)/debian/mcbot install |
50 $(MAKE) DESTDIR=$(CURDIR)/debian/mcbot install |
51 cp config/.mcbotrc debian/mcbot/var/lib/mcbot/ |
51 cp config/.mcbotrc debian/mcbot/var/lib/mcbot/ |
56 |
56 |
57 # Build architecture-dependent files here. |
57 # Build architecture-dependent files here. |
58 binary-arch: build install |
58 binary-arch: build install |
59 dh_testdir |
59 dh_testdir |
60 dh_testroot |
60 dh_testroot |
61 dh_installchangelogs |
61 dh_installchangelogs |
62 dh_installdocs |
62 dh_installdocs |
63 dh_installexamples |
63 dh_installexamples |
64 # dh_install |
64 # dh_install |
65 # dh_installmenu |
65 # dh_installmenu |
66 # dh_installdebconf |
66 # dh_installdebconf |
67 # dh_installlogrotate |
67 # dh_installlogrotate |
68 # dh_installemacsen |
68 # dh_installemacsen |
69 # dh_installpam |
69 # dh_installpam |
70 # dh_installmime |
70 # dh_installmime |
71 # dh_python |
71 # dh_python |